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1 What is the Form-making label file? 
The Form-making data format starts with the FS command, followed by a string 
inside closed quotation marks “ ” for the form name and ends with the FE 
command. Anything between FS and FE is the label content. An example of a 
complete Form-making label file (i.e. the Form name is “EXPORT”) is provided 
below: 
ZN 
FK"EXPORT" 
FS"EXPORT" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
FE 

2 The Purpose of the Form-making label file 
The label file can be stored in ArgoKee or the printer. The input devices for 
different storage devices are as follows: 
2.1 ArgoKee 
The device shown in the illustration below can be used for data input. 

 
2.2 Printer 
A PS/2 keyboard or scanner must be used as the data input device. A PC can also 
be used to send commands directly to the printer for printing Form-making label 
files. 

3 Supported Versions 
BarTender 9.30 2731 or later versions 
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Seagull Driver 7.2_M-1 or later versions 
Attention:  Make sure both devices software are the latest versions. If there an 
error occurs during the data conversion, check the software versions first. 

4 Supported Languages 
Currently, it is only supported PPLB. The Seagull Driver for PPLB must be used 
for data conversion. 

5 Form-making conversion for BarTender 
Since the Form-making data format is different from the original emulation, it 

must be converted using a different method/path. The path is “File -> Export 
Printer Code Template”. 
The three conversion methods currently offered by BarTender are “Argox 
ArgoKee(SRAM)”, “Argox ArgoKee(FLASH)”, and “Argox 
READER(FLASH)”. 

 

A description and comparison of these methods will be provided below. 
For example, the Argox X-3200 PPLB will be used below to create a 4 X 3 inch 
blank label for data conversion: 
5.1 Argox ArgoKee(SRAM) 

5.1.1 Purpose 
To be used with ArgoKee and printers. 
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5.1.2 Comparison 
The data saved to ArgoKee will always be stored to FLASH. On the 
other hand, the data saved to the printer will always be stored to RAM. 
And those data saved in printers will therefore disappear when power is 
lost. 

5.1.3 Data conversion 
ZN 
FK"EXPORT" 
FS"EXPORT" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
FE 

5.2 Argox ArgoKee(FLASH) 
5.2.1 Purpose 

To be used with ArgoKee and printers. 
5.2.2 Comparison 

Both data are stored to FLASH, so data will not disappear when power 
is lost. 

5.2.3 Data conversion 
ZS 
FK"EXPORT" 
FS"EXPORT" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
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FE 
ZN 

5.3 Argox READER(FLASH) 
5.3.1 Purpose 

To be used with ArgoKee and printers. 
5.3.2 Comparison 

Both data are stored to FLASH. The difference the two devices, the 

Form name for the “Argox ArgoKee(FLASH)” is always “READER” 
with all capital letters. This option is mainly intended for a scanner 
usage as the data input device. For this reason, it has one extra 

command compared to “Argox ArgoKee(FLASH)”: “PA1,1”. The 
command means print one copy only. If it is saved to ArgoKee, the user 
will not be prompted to enter the number of copies after entering the 
data. One copy will be printed directly. 

5.3.3 Data conversion 
ZS 
FK"READER" 
FS"READER" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
PA1,1 
FE 
ZN 

6 Downloading the Form-making label file 
For example, the Argox X-3200 PPLB will be used below to create a 4 X 3 inch 
blank label. 
6.1 Installing the driver 

Use the Seagull Driver to install the driver for Argox X-3200 PPLB. Set the 

“Ports” as “COM1” and the printer details should be as shown below. 
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6.2 Set baud rate 

The default baud rate for the printer and ArgoKee's COM Port is 9600, so 
the COM Port for the PC, printer and ArgoKee should be set to the value 
shown below. The illustration shows the three default settings and if one of 
the settings is changed, the other two settings must be changed as well for a 
proper connection. Details are beyond the scope of this manual. 
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6.3 Create label and select output printer 

6.3.1 After launching BarTender, select “File -> New”. The “New Label 
Format Wizard” window appears on the screen. 

 
6.3.2 Follow the wizard's instructions to select “Starting Point -> Printer 

Selection -> Stock Selection -> Label Stock -> Side Edges -> Label 
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Shape -> Label Size -> Finished”. After completing the installation, 
select Argox X-3200 PPLB for creating a 4 X 3 inch blank label as 
shown below.  

 
6.4 Download Form-making label file 

The methods for downloading to ArgoKee and the printer mentioned in 
section 2 are described below: 
6.4.1 Downloading to ArgoKee 

6.4.1.1 First, check that the transmission setting between the PC and 
ArgoKee compatible with each other, then connect both COM 
Port with the data cable. Next, press the "D" key on the ArgoKee 
to enable data receive mode. The LCD on ArgoKee will now 

show the message “LOADING FORM … (HOST ==> 
K/BOARD)”. 

6.4.1.2 Use the blank label file created in section 6.3 or another file that 

has been prepared earlier, then select “File -> Print”. A window 
will pop up as shown below. At the “Print -> Name” window, 
select the “Argox X-3200 PPLB” printer, and then click 
“Close”. 
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6.4.1.3 Under “File -> Export Printer Code Template”, run “Argox 

ArgoKee(SRAM)” or ”Argox ArgoKee(FLASH)”. The 
“Export Printer Code Template” window will appear as shown 
below. 

 
6.4.1.4 Select “More Options” and the following window appears on 
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the screen. The system defaults for “Job Options” are: 
“Format ID/Name” : “Type” => “Set By Driver”. 
“Identical Copies” and “Serialized Copies” : “Type” => “Set by 
Print Dialog”. 
Attention: To customize the Form name, at “Format ID/Name”, set 
“Type” to “Constant”, then enter the required name in “Name/Value”. 

 

 

 

The competed settings are shown on the above illustration. Finally, 

click “OK”, then “Export”. 
6.4.1.5 If the download is successful, ArgoKee's LCD will exit the 

“LOADING FORM … (HOST ==> K/BOARD)” mode. 
Otherwise, it will remain in the same mode. 

6.4.1.6 During the above downloading process, if the system default was 
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used, then the Form name will be “EXPORT”. To verify if the 
Form-making has been successfully loaded, press the “P” key on 
ArgoKee to enter print mode. ArgoKee's LCD will display 

“FORM SELECTION:”. Press the “Up/Down” keys to look for 
the newly downloaded Form-making. If it exists, it means the 
downloading process was successful. 

6.4.2 Download to printer 
6.4.2.1 First, make sure that the PC and the printer are both using the 

right transmission settings, then connect both COM Port with the 
data cable. Turn on the printer, then wait for the message 

“READY (300,PPLB)” to appear on the printer's LCD. 
6.4.2.2 Follow the steps in section 6.4.1.2. 

6.4.2.3 Under “File -> Export Printer Code Template”, select “Argox 
ArgoKee(FLASH)” or “Argox READER(FLASH)”. 

6.4.2.4 Follow the steps in section 6.4.1.4. 
6.4.2.5 The printer LCD will not show any messages if the download 

was successful. There are several another methods to verify the 
downloading status such as sending a command to the printer, or 
plugging in a PS/2 keyboard then checking via the printer LCD.  

6.4.2.6 During the above downloading process, if the system defaults 

were used, then “Argox ArgoKee(FLASH)” will have the Form 
name “EXPORT”. “Argox READER(FLASH)” will have the 
Form name “READER”. 

7 Using the Form-making label file 
7.1 Using ArgoKee to input data 

7.1.1 If “Argox ArgoKee(FLASH)” was used to download a Form-making 
to ArgoKee, if the defaults were used, then ArgoKee will contain a 
Form named “EXPORT”. 

7.1.2 Connect ArgoKee to the printer using the COM Port cable. ArgoKee 
now becomes an input device. 

7.1.3 At ArgoKee's “S:SET -> EMULATION :”, use the “Up/Down” keys 
to toggle the following settings: ”PPLA/PPLB/BASIC”. Switch to 
“PPLB”, then press “Enter” to confirm. Now press “<ESC>” to exit 
and reboot ArgoKee. 

7.1.4 Once ArgoKee reboots, the LCD will display “PPLB MODE 
SELECTION: P:PRINT, D:DL, S:SET”. Now, press “P” and the 
ArgoKee LCD will display the name of a stored Form. Use the 
“Up/Down” keys to browse the forms and press the “Enter” key to run 
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the selected Form. If data input is needed for Form, then ArgoKee will 
enter data input mode. The printer LCD will display the “Prompt Text”. 

7.2 Using PS/2 keyboard to enter the data. 

7.2.1 If “Argox ArgoKee(FLASH)” was used to download a Form-making 
to the printer, if the defaults were used, then the printer will contain a 
Form named “EXPORT”. 

7.2.2 First, connect the PS/2 keyboard to the printer, then start the X-3200 
PPLB. Wait for few moments, then the printer LCD will show the 

message “READY (300,PPLB) <ESC> FOR KEYBD”. Press the 
“<ESC>” key on the keyboard to enter the data. 

7.2.3 The printer LCD will now show the name of a Form stored on the 
printer. Use the “Up/Down” keys to browse all the Forms, then click on 
the “Enter” key to execute the selected Form. If the Form being 
executed requires a data input, the printer will enter data input mode 

and display the “Prompt Text” on the LCD. The “Prompt Text” can be 
modified in BarTender. 

7.2.4 To leave the data input mode, simply disconnect the PS/2 keyboard and 
turn off the printer. 

7.3 Using a scanner to input data 

7.3.1 If “Argox READER(FLASH)” was used to download a Form-making 
to the printer, and if the defaults were used, then the printer will 
contain a Form named “READER”. 

7.3.2 Start the X-3200 PPLB, then in the printer Menu, set the “READER 
INSTALLED” setting to “YES”, save, and then reboot. 

7.3.3 After printer reboots, it will find a Form named “READER” in Flash 
and run it. If the Form requires data input the printer will enter data 

input mode and display the “Prompt Text” on the LCD. The “Prompt 
Text” can be modified in BarTender. 

7.3.4 Now connect the scanner to the printer using a PS/2 cable to allow data 
input. 

7.3.5 To exit the data input mode, press and hold the “CANCEL/RESET” 
button on the printer before turning the printer on. Wait until the printer 

LCD shows the string “RESET” before releasing the 
“CANCEL/RESET” button. Only then will the printer exit the data 
input mode. 

8 Data variables in Form-making 
The next chapter uses the X-3200 PPLB printer as an example. The following 
simple examples will only require converted data. There are two methods for 
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acquiring the output file data. 

The first method: Change the printer's “Ports” under “FILE” in “Start -> 
Printers and Faxes -> Argox X-3200 PPLB -> Properties -> Ports”. Check 
“FILE”, and then click “OK”. 

 
The second method: Use the “Printer Code Recording” function offered by 
Seagull Driver. The path “Start -> Printers and Faxes -> Argox X-3200 PPLB 
-> Properties -> Tools -> Logging Options -> Printer Code Recording”. 
Check “Record Printer Code”, and then click “OK”. For more information, 
please refer to the “Guide to Argox Printer Transmission Information.doc”. 
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Following example, we chose the first method. Before continuing on to the 
following example, follow the steps outlined in section 6.4.1.2 to select the 
Argox X-3200 PPLB printer, create a 4 X 3 inch blank label, and then convert it 

using the “Argox ArgoKee(FLASH)” method. 
8.1 TT variable 

8.1.1 Select “Create -> Bar Code”, then click anywhere on the label to 
create a “Bar Code Object”. 

 
8.1.2 Right-click on the “Bar Code Object”, then in the newly opened 
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window, clicks “Properties”. The window for modifying the content 
of the “Bar Code Object” will now appear. 

8.1.2.1 Bar Code 

Check the “Print Method -> Bar codes and human readable text 
controlled by the printer” option. If this option is not available, 
then the “TT” variable output is not available. 

The barcode type can be changed in the “Symbology” menu. 

 

 
8.1.2.2 Font 

An Argox font must be selected. A wrong selection will result the 
“TT” variable cannot be converted. 
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8.1.2.3 Data Source 

Select “Source -> Time” and check “Use Printer’s Clock”. If the 
option is not checked, the “TT” variable cannot be converted. 

The time format can be changed in the “Time Format” menu. 
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8.1.2.4 General 

Verify that the “Object Name” is “Bar Code 1”. 

 
8.1.2.5 Any other changes can also be set here. When done, click “OK”. 

8.1.3 Under “File -> Export Printer Code Template”, run “Argox 
ArgoKee(FLASH)” and the “Export Printer Code Template” 
window will appear as shown below. 

 
8.1.4 Carry out the steps from section 6.4.1.4. As an example, we changed 

the Form name to “TIME”, then click “Export”. 
8.1.5 Data conversion 
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ZS 
FK"TIME" 
FS"TIME" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
TTh/Zm + 
B900,781,2,3,4,10,150,B,TT 
FE 
ZN 

8.2 TD variable 

8.2.1 Select “Create -> Text”, then click anywhere on the label to create a 
“Text Object”. 

 

8.2.2 Right-click on the “Text Object”, then in the newly opened window, 

clicks “Properties”. The window for modifying the content of the 
“Text Object” will now appear. 

8.2.2.1 Font 
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An Argox font must be selected. A wrong selection will result the 
“TD” variable cannot be converted. 

8.2.2.2 Data Source 

Select “Source -> Date” and check “Use Printer’s Clock”. If the 
option is not checked, the “TD” variable cannot be converted. 

The date format can be changed in the “Date Format” menu. 

 
8.2.2.3 General 

Verify that the “Object Name” is “Text 1”.  
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8.2.2.4 Any other changes can also be set here. When done, click “OK”. 

8.2.3 Carry out the steps from section 8.1.3-8.1.4. As an example, we 

changed the Form name to “DATE”, then click “Export”. 
8.2.4 Data conversion 

ZS 
FK"DATE" 
FS"DATE" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
TDmn/dd/y2 
A923,764,2,3,4,4,N,TD 
FE 
ZN 

8.3 V variable 
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8.3.1 Select “Create -> Bar Code”, then click anywhere on the label to 
create a “Bar Code Object”. 

 

8.3.2 Right-click on the “Bar Code Object”, then in the newly opened 

window, clicks “Properties”. The window for modifying the content 
of the “Bar Code Object” will now appear. 

8.3.2.1 Bar Code 

Check the “Print Method -> Bar codes and human readable text 
controlled by the printer” option. If this option is not available, 
then the “V” variable output is not available. 

The barcode type can be changed in the “Symbology” menu. 
8.3.2.2 Font 

An Argox font must be selected. A wrong selection will result the 
“V” variable cannot be converted. 

8.3.2.3 Data Source 

Select “Source -> Printer Code Template Field”, then enter a 
non-null string for “Sample Data”. In this example, the string 
“test” was entered. If a null string was entered and it is referred by a 
“Text Object”, then the text object cannot be converted into the 
corresponding “V” variable. 
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Next, select “More Options”. Then in the “More Data Source 
Options” window, under “Prompting -> Prompt Text”, enter the 
message prompt for ArgoKee or the printer should prompt for data 

input. For example, in the following illustration the “Prompt Text” 
is “INPUT DATA”. When done, click “Close”. 
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8.3.2.4 General 

Verify that the “Object Name” is “Bar Code 1”. 
8.3.2.5 Any other changes can also be set here. When done, click on 

“OK”. 
8.3.3 Carry out the steps from section 8.1.3-8.1.4. As an example, we 

changed the Form name to “VVARIABLE”, then click on “Export”. 
8.3.4 Data conversion 

ZS 
FK"VVARIABLE" 
FS"VVARIABLE" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
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N 
V00,20,N,"INPUT DATA" 
B817,781,2,3,4,10,150,B,V00 
FE 
ZN 

8.4 C variable 

8.4.1 Select “Create -> Text”, then click anywhere on the label to create a 
“Text Object”. 

 

8.4.2 Right-click on the “Text Object”, then in the newly opened window, 

clicks “Properties”. The window for modifying the content of the 
“Text Object” will now appear. 

8.4.2.1 Font 
An Argox font must be selected. A wrong selection will result the 
“C” variable cannot be converted. 

8.4.2.2 Data Source 

Select “Source -> Printer Code Template Field”, and then enter a 
non-null string for “Sample Data”. In this example, the string 
“test” was used as the input. If a null string was used here, the “C” 
variable or “V” variable cannot be converted. Here, it is the “C” 
variable that cannot be converted. 

Next, select “More Options”. Then in the “More Data Source 
Options” window, under “Prompting -> Prompt Text”, enter the 
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message prompt for ArgoKee or the printer should prompt for data 

input. For example, in the following picture the “Prompt Text” is 
“SERIAL COUNT”. 

Check the “Serialization -> Serialize” option. If the option is not 
checked, then the “C” variable cannot be converted. When done, 

click “Close”. 

 
8.4.2.3 General 

Verify that the “Object Name” is “Text 1”. 
8.4.2.4 Any other changes can also be set here. When done, click “OK”. 

8.4.3 Carry out the steps from section 8.1.3-8.1.4 but at “Job Options -> 
Serialized Copies” setting, change the type to “Template Field”. A 
constant number such as 1 must also be given for the “Name/Value” 
field or the “C” variable cannot be converted. As an example, we 

changed the Form name to “CVARIABLE”. Finally, click “Export”. 
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8.4.4 Data conversion 
ZS 
FK"CVARIABLE" 
FS"CVARIABLE" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
ZN 
C0,20,N,+1,"SERIAL COUNT" 
A770,764,2,3,4,4,N,C0 
FE 
ZN 

8.5 Reference 

8.5.1 Carry out the steps from section 8.3.1-8.3.2. The “Object Name” of 
this “Bar Code Object” is “Bar Code 1”. 

8.5.2 Next, select “Create -> Text”, then click anywhere on the label to 
create a "Text Object". 
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8.5.3 Right-click on the “Text Object”, then in the newly opened window, 

clicks on “Properties”. The window for modifying the content of the 
“Text Object” will now appear. 

8.5.3.1 Font 
An Argox font must be selected. A wrong selection will result the 
corresponding variable cannot be converted. 

8.5.3.2 Data Source 

Select “Source -> Label Object String”. The next step is setting 
the reference object and information. 

Select the reference object at “Options -> Object Name”. Then 
select the previously created “Bar Code 1”. Next, select “String -> 
Main Data Source”. A wrong selection will result the 
corresponding variable cannot be converted. 
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8.5.3.3 General 

Verify that the “Object Name” is “Text 1”. 
8.5.3.4 Any other changes can also be set here. When done, click “OK”. 

8.5.4 Carry out the steps from section 8.1.3-8.1.4. As an example, we 

changed the Form name to “REFERENCE”, then click “Export”. 
8.5.5 Data conversion 

ZS 
FK"REFERENCE" 
FS"REFERENCE" 
I8,1,001 
q1215 
S4 
O 
JF 
ZT 
Q900,37 
�KI81 
N 
V00,20,N,"INPUT DATA" 
B888,781,2,3,4,10,150,B,V00 
A758,410,2,3,4,4,N,V00 
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FE 
ZN 


